Degraded Performance: Outbound WhatsApp Messaging Failures
Resolved
Jun 12, 2026 at 5:39pm UTC
Meta has officially confirmed that the upstream issues impacting the WhatsApp Cloud API have been fully resolved and services are restored.
Our system metrics have completely returned to normal, and all outbound WhatsApp messaging is functioning as expected. Any message backlogs that built up during the peak of the outage have now fully cleared.
Current State: 100% Operational.
Action Required: None. All messaging services are running normally.
Thank you so much for your patience and understanding while we monitored this disruption!
Affected services
Updated
Jun 12, 2026 at 4:10pm UTC
Update: We are seeing a significant recovery in our outbound WhatsApp messaging traffic, and messages are currently processing and sending normally on our platform.
Please note that while our internal metrics show that service has stabilized, Meta has not yet officially updated their status page to "Resolved." Because of this, we are keeping our status at Degraded to ensure traffic remains stable and no residual errors occur.
Current Status: Outgoing messages are flowing normally.
Our engineering team is staying on high alert. We will change this status to "Resolved" the moment Meta officially closes out the incident on their end.
Affected services
Updated
Jun 12, 2026 at 3:01pm UTC
Meta has officially confirmed a widespread disruption impacting the WhatsApp Cloud API.
Because our platform relies on this global infrastructure to route your communications, this upstream issue is directly causing the failures and severe delays you are currently experiencing with outgoing WhatsApp messages.
Current Impact: Outgoing WhatsApp messages are failing to send or stuck in transit.
Our Action: We are closely monitoring Meta’s engineering teams as they work on a fix.
Meta scheduled their next internal update for roughly 30 minutes from now. We will update this status page the second we receive new information or see signs of recovery.
Affected services
Created
Jun 12, 2026 at 1:54pm UTC
We have identified an issue impacting our WhatsApp outbound messaging service. This appears to be related to an upstream issue with the WhatsApp/Meta API, causing message delivery failures and high latency.
Impact: Delayed or failed delivery for outgoing WhatsApp messages.
Current Action: We are monitoring Meta's status updates closely and working to mitigate the impact on our routing layer where possible.
We appreciate your patience and will keep this page updated with real-time progress as Meta resolves the underlying issue.
Affected services